Настройке real time статистики

Advanced Mass Sender tech support

Модераторы: partnerweb, Max Terentiev

Ответить
Сообщение
Автор
slavqache
Сообщения: 6
Зарегистрирован: Ср окт 15, 2014 8:32 pm

Настройке real time статистики

#1 Сообщение slavqache » Ср окт 15, 2014 8:36 pm

Здравствуйте.
Нужно настроить, чтобы письма показывались при открывании.
Помогите пожалуйста подробной инструкцией или ссылкой на мануал.

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#2 Сообщение Max Terentiev » Чт окт 16, 2014 10:02 am

Нужно сделать следующее:

1. Зайти на ваш сайт фтп клиентом, создать в корне сайта новую папку с любым именем, например – stat.

2. Скопировать в эту папку скрипт amsweb.php и файл .htaccess из папки c:\Program Files (x86)\AMSEnt\ServerSide\

В целях безопасности, перед загрузкой скрита, его стоить открыть в Нотпаде и самом начале поменять пароль для доступа. По умолчанию там стоит qwerty, лучше указать другой.

3. Задать права доступа 755 для amsweb.php И для папки на сервере, куда вы его скопировали.

4. В AMS зайти в Настройки->RealTime статистика и добавить ссылку на установленный скрипт. Т.е. http://www.VashSite.ru/stat/amsweb.php а так же пароль, который вы прописывали на шаге 2.

На этом настройка завершена. Теперь, в редакторе писем вы можете включить Счетчик открытых писем (меню редактора RealTime статистика), а так же сделать нужные ссылки в письме «остлеживаемыми» - выделить ссылку, кликнуть на иконку гиперссылки на тулбаре редактора и поставить галку Отслеживать клики по этой ссылке.

slavqache
Сообщения: 6
Зарегистрирован: Ср окт 15, 2014 8:32 pm

#3 Сообщение slavqache » Чт окт 16, 2014 3:00 pm

Спасибо, все так и сделал.
Ситуация вкратце такая:
Разослал сегодня очень рандомизированное письмо по базе в 2600 человек. Статистика показала "Отправлено писем 850", "Не отправлено 1350". По открытым статистика показывала ноль.

Сейчас нажал на "Перепослать на неотправленные", в результате чего сейчас все 2600 отправлены, неотправленных 0. По прежнему 0 открытых.

В чем может быть ситуация? Почему во второй раз сразу отправилось все?

slavqache
Сообщения: 6
Зарегистрирован: Ср окт 15, 2014 8:32 pm

#4 Сообщение slavqache » Чт окт 16, 2014 4:17 pm

Сейчас попробовал разослать тоже письмо по своим только адресам. Составил мини список рассылки в 5 своих адресов и разоаслал.

Статистика показывает 5 отправлено, 0 не отправлено. Но ни в одном ящике нет письма, причем ни в инбоксе, ни в спаме.

В чем может быть проблема?

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#5 Сообщение Max Terentiev » Чт окт 16, 2014 4:30 pm

Стукните в скайп - maxterentiev

Зайду к вам через тим вьювер и проверю настройки.

Аватара пользователя
partnerweb
Сообщения: 335
Зарегистрирован: Вс мар 18, 2012 9:42 am

#6 Сообщение partnerweb » Вс окт 19, 2014 8:36 am

А Вы случано не положили файлик на хостинг с дефолтовым названием? :)
По идее кроме названия в файлике было бы не плохо еще кое что дописать ...

Изображение
Изображение
Толерантность - добровольное страдание, приводящее к уничтожению иммунитета индивидуума.
Тех.поддержкой не занимаюсь.

slavqache
Сообщения: 6
Зарегистрирован: Ср окт 15, 2014 8:32 pm

#7 Сообщение slavqache » Вс окт 19, 2014 8:59 am

Сделал как написано в "справке". Открыл корень, создал папку "AMS", закинул туда скрипт "amsweb.php". В общем то все.

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#8 Сообщение Max Terentiev » Пт ноя 07, 2014 11:57 am

Возможно PHP на вашем не содержит расширения Mcrypt или mbstring. Обычно их можно включить/добавить через личный кабинет хостинга.

frankus_
Сообщения: 5
Зарегистрирован: Вт ноя 11, 2014 12:48 am

#9 Сообщение frankus_ » Вт ноя 11, 2014 1:19 am

"make copy command return empty file" что это значит?? работает статистика или нет??

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#10 Сообщение Max Terentiev » Вт ноя 11, 2014 2:08 am

Если кликнули на отслеживаемые ссылки, приняли статистику и число кликов изменилось - значит работает. В противном случае - нет.

ideal13
Сообщения: 15
Зарегистрирован: Вт авг 26, 2014 8:55 am

#11 Сообщение ideal13 » Вт фев 02, 2016 8:34 pm

Всё сделал как говорите. При нажатии кнопки "Retreive now" пишет "error: makecopy command failed ams"
Помогите.

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#12 Сообщение Max Terentiev » Ср фев 03, 2016 4:27 am

Установите на сайт скрипт из последней версии 2.99.9 после чего откройте ссылку на скрипт в браузере. Обновленный скрипт сделает самодиагностику и в случае проблем будет понятно из-за чего они возникли.

Spiric
Сообщения: 2
Зарегистрирован: Вт сен 20, 2016 2:00 pm
Контактная информация:

Скрипт на стороне сервера работает

#13 Сообщение Spiric » Вт сен 20, 2016 2:18 pm

Добрый день скрипт на стороне сервера выдает:
Проверка установки и работоспособности скрипта...

Версия PHP: 5.4.45

Расширение mbstring: OK
Расширение mcrypt: OK
Функция mcrypt_cbc: OK
Функция mb_detect_encoding: OK

Пытаемся создать файл test.log... OK
Пытаемся записать данные в файл...OK
Пытаемся скопировать test.log -> test.out...OK

Проверка прошла успешно, скрипт установлен и функционирует правильно !

Но в программе самой при Ошибка команды Make Copy.

Статистику не подтягивает по открытым.

Можете разъяснить в чем дело?

Аватара пользователя
Max Terentiev
Admin
Сообщения: 1668
Зарегистрирован: Сб мар 27, 2004 12:01 am
Откуда: Санкт-Петербург
Контактная информация:

#14 Сообщение Max Terentiev » Ср сен 21, 2016 10:24 am

Добрый день,

Попробуйте скачать этот билд:

http://www.bspdev.ru/b1254.zip

Распакуйте архив в папку с амс поверх старого файла.

В этом билде изменен User-Agent в http запросе, у одного из пользователей из-за этого была аналогичная проблема.

По результатам отпишите пожалуйста, ушла ли проблема ?

Spiric
Сообщения: 2
Зарегистрирован: Вт сен 20, 2016 2:00 pm
Контактная информация:

#15 Сообщение Spiric » Ср сен 21, 2016 1:55 pm

Max Terentiev писал(а):Добрый день,

Попробуйте скачать этот билд:

http://www.bspdev.ru/b1254.zip

Распакуйте архив в папку с амс поверх старого файла.

В этом билде изменен User-Agent в http запросе, у одного из пользователей из-за этого была аналогичная проблема.

По результатам отпишите пожалуйста, ушла ли проблема ?
Установил новый билд - все заработало, спасибо большое.

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость